HCNA NOTE

HCNA NOTE

HCNA 学习笔记

网络整体架构

企业网络

企业网络:包括小型办公室、教育、政府、银行等行业或机构

  • 企业网络远程互联:

总公司与分公司使用广域网链路(WAN)互联

企业网络基本架构

  1. 小型企业:通常采用扁平网络结构,扩展能力低。
  2. 大型企业:通常采用层次化结构以支撑网络的扩展和用户的增长。
  • 结构图(左小右大)

网络基本管理及模拟器使用

常用的传输介质

双绞线、光纤、Radio(蓝牙等)、同轴电缆(几乎淘汰)

双绞线(8芯)

有多种类型,不同类型传输速度不同和,超5类、6类最常用。RJ-45水晶头

568A标准:白绿,绿,白橙,蓝,白蓝,橙,白棕,棕
568B标准:白橙,橙,白绿,蓝,白蓝,绿,白棕,棕

交叉线:一头采用568A标准,一头采用568B标准
平行线/直通线:两头采用同样的标准(同为568A标准或568B标准)

相同设备使用交叉线,不同设备使用直通线,现在很多设备都有自适应。

光纤

单模光纤(S):颜色多为黄色,连接头多为蓝色或绿色,只能传输一种模式的广。不存在模间色散,适用于 长距离高速传输
多模光纤(M):线缆颜色千兆多位橙色、万兆多为水蓝色,连接头多位灰白色,允许不同模式的光在一根光纤上传输,由于模间色散较大而导致信号脉冲展宽严重,因此主要用于局域网的短距离传输。

区别:主要在传输距离,单模长距离,多模短距离。单模和多模差异在传输距离

洲际的传输使用的是 光缆,不是光纤。

常用光纤连接器:ST,FC,SC,LC连接器。连接器有帽子,要拿掉才能连接。

串口电缆

网络通信中常用和推荐的串口电缆标准为 RS-232,但传输速率有限仅为6米。
RS-422和RS-485的传输距离可达1200米。接头常用V.35(80年代淘汰),但仍在帧中继、ATM等传统网络上使用。
V.24为RS-232标准的欧洲版,RS-232本身没有定义接头标准,RS-232逐渐被FireWire,USB等取代。新产品和设备已经普遍使用USB标准。

ENSP 模拟器

关闭Windows防火墙,不要装各种管家。
尽量少运行软件,可能会干扰 virtunal-box。
重新注册要关闭ENSP,个人文件夹下的.VirtualBox彻底删除。注册完毕之后关闭ENSP然后再开启。

冲突域

应用场景:多点接入网络(MA),如交换机(Switch)

冲突域与半双工搭配

单工:简单的说就是一方只能发信息,另一方则只能收信息,通信是单向的。
半双工:比单工先进一点,就是双方都能发信息,但同一时间则只能一方发信息。
全双工:比半双工再先进一点,就是双方不仅都能发信息,而且能够同时发送。

半双工和全双工都支持双向数据传输。

共享式网络中,不同的主机同时发送数据时,就会产生信号冲突的问题,解决方法一般是:采用载波侦听多路访问/冲突检测技术(CAMA/CD)的基本工作过程如下:

  1. 终端设备不同地检测共享网路的状态。如果线路空闲,则可以发送数据,线路不空闲,则等待一段时间后据徐检测(延时时间由退避算法决定)。
  2. 如有另一个设备同时发送数据,两个设备发送的数据会产生冲突。
  3. 终端设备检测到冲突之后,马上停止发送自己的数据,并发送特俗阻塞信息,以强化冲突信号,使线路上的其他站点能够尽早检测冲突。
  4. 终端设备检测到冲突后,等待一段时间后再将进行数据发送(延时时间由退避算法决定)。

CSMA/CD 的工作原理:先听后发,边发边听,冲突停发,随机延迟后重发。

Q:用串行线路能否构建MA网络
A:肯定可以

NBMA(非广播多路访问):物理架构(ATM、帧中继网络)—-NMBMA(网络设计)—VPN(DSVPN)。

熟悉以及远程管理设备的实验

1
2
3
system-view
interface GigabitEnternet0/0/0/0 # 进入接口
ip address 10.1.1.1 255.255.255.0

常用命令

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
sysname R1 # 修改设备名字
ip address 10.1.1.1.7 # 配置IP地址
ip address mask 10.1.1.1.7 24 # 配置IP地址和掩码
diaplay this # 显示当前模式
dis ip int bri # 查看接口开启情况
undo shutdown #
q # 退出

user-interface # 用户接口
user-interface ? # 查看帮助

user-interface vty 0 4 # 开启虚拟终端管理
set authentication password cipher pass # 设置认证密码为pass

talent 10.1.1.1 # 远程管理设备,不能进入system-view

diaplay ip routting0table # 查看路由表

网络各种分层结构

网络分层基础

网络的层次化不要以设备最为标准,要以协议作为分层的标准。

OSI(开放式系统互联模型) 七层模型:

  1. 应用层:为应用程序提供网络服务
  2. 表示层:数据格式化,加密、解密,如:jpg,gif
  3. 会话层:建立、维护、管理会话连接,系统(Linux,iOS,Android)在此
  4. 传输层:建立、维护、管理端到端连接,单位:段(segment),TCP/UDP连个协议
  5. 网络层:IP寻址和路由选择,单位:包,有200多个协议
  6. 数据链路层:控制网络层与物理层之间的通讯,单位:帧(frame)
  7. 物理层:比特流传输,单位:比特(bit)

应用层、表示层、会话层:单位统称为:协议数据单元(PDU)
物理层在TCP/IP中被称为互联网层(Internet Protocal)

TCP/IP(工业标准)

  1. 应用层 (TELNET、FTP、SMTP)
  2. 传输层 (TCP、UDP)
  3. 互联网层 (IP、ICMP),路由
  4. 网络接口层 (PPP),交换

数据封装

批注 2019-10-19 142448.png

每一层都有一个头部

TCP与UDP的概念相互的区别及优劣

  1. TCP面向连接,UDP面向无链接
  2. TCP面向报文,UDP面向字节流
  3. TCP提供可靠传输服务(数据顺序、正确性),UDP传输不可靠
  4. TCP协议传输速度慢,UDP协议传输速度快
  5. TCP协议对系统资源要求多(头部开销大),UDP协议要求少*

VRP 的操作

管理vlan(虚拟局域网)

SW1
1
2
3
4
5
system-view
sysname SW1
interface vlanif 1
ip address 10.1.1.1 24
display this
SW2
1
2
3
4
system-view
sysname SW2
interface vlan 1
ip address 10.1.1.2 24

ENSP自带了网络报文解析器。右键设备-数据抓包

Ehternet基础

网络中传输数据时需要定义并遵循一些标准,以太网是根据IEEE802.3 标准来管理和控制数据帧的。了解IEEE802.3标准是充分理解以太网中链路层通讯的标准。

  • IEEE 是局域网标准

以太网帧

以太网(最流行,最常用,效率最高),它的数据链路层基于MAC地址进行帧的传输。
PR:
FR(MA网络):帧中继靠的是DLCI
PPP(ppp网络)、HDLC(ppp网络):什么都不靠

以太网MAC地址

以太网的MAC地址(Media Access Control Address):
由两部分组成:前24位的供应商代码、后24位的序列号。供应商代码由IEEE管理和分配。

OUI:厂商序号

MAC分类

单一的源段发送到单一的目的端,每个主机接口由一个MAC地址唯一标识,MAC地址的OUI中第一字节第8个比特表示地址类型,对于主机MAC地址这个比特固定为0如,表示目的的MAC地址为此MAC地址的帧都是发送到某个唯一的端。在冲突域中,所有主机都能收到源主机发送的单播帧,但其他主机发现目的地址与本地MAC地址不一致后会丢弃收到的帧,只有真正的目的主机才会接收并处理收到的帧

单播MAC(1 V 1):01001100 第一字节的最后一位:0
组播MAC(1 V n): 00000001 第一字节的最后一位:1
广播MAC(1 V all): F1111111 第一字节的最后一位:1

01005E:经典的组播MAC

以太网封装格式

以太网两种最常用的以太网封装格式:以太2型和802.3

80年代初:DIX v2,1983年:提出IEEE8.2.3

类型的位置除了IP(0800)还有ARP(0806),PPPoE,MP,IPv6c

两种协议的主要区别在于:

EnternetII格式中包含一个Type字段,标识以太网帧处理完成值后将被发送到哪个上层协议进行处理。IEEE802.3格式同样的位置是长度字段。

以太网帧中的Type字段为0X0800,表示该帧的网络层协议为IP协议。

不同的Type字段值可以用来区别这两种帧的类型:

EnternetII格式: Length/Type >= 1536(0x0600)

IEEE802.3格式: Length/Type <= 1500(0x05DC)

以太网帧中还包括源和目的的MAC地址,分别代表发送者和接受者的MAC,此外还有帧校验序列字段,用于检验传输过程中的完整性。

以太网IP地址网络基础和FTP

IP编制

IP编制组成

  1. IP 地址分为网络部分和主机部分
  2. IP 地址由32个二进制位组成,通常用点分十进制形式表示。
  • IP报文头部

Tyep[Data] 的 1500 包括IP报头

以太网IPv4基础和分类

/8:代表掩码,作用:区分网络和主机,代表8个连续的1(255.0.0.0)
127.0.0.0/8 :网络(主机位全为0)
127.255.255.255/8 :广播地址(主机全为1)

每个网段上有两个特俗地址不能分配给主机或网络设备。(除网络地址和广播地址外的其他IP地址可以作为网络设备的IP地址)

  1. IP地址主机位全为0(而不是无端一定为0),表示一个网段。

  2. 该网段中的广播地址,目的地址为广播地址的报文会被该网段中的所有网络设备接受,广播地址的主机位全为1.

网络的进制

二进制,十进制,十六进制(MAC)

IPv4地址分类

地址范围

A类:1.0.0.1126.255.255.254
B类:128.1.0.1
191.255.255.254
C类:192.0.1.1223.255.255.254
D类:224.0.0.0~239.255.255.255
E类:240.0.0.1
255.255.255.254

  • NET: ABCDE的有类网络
  • subset:即子网(一个大的网络划分成小的网络)

10.2.8.3/24 可以容纳的主机:2^8-2

IP地址类型

互联网标准:RFC

  • 私有地址
  1. 10.0.0.0~10.255.255.255
  2. 127.16.0.0~127.31.55.255
  3. 192.168.0.0~192.158.255.255
  • 特俗地址
  1. 127.0.0.0~127.255.255.255, 127.0.0.1主机环回地址
  2. 0.0.0.0
  3. 255.255.2555.255(本地广播地址,是0.0.0.0的广播地址)

子网掩码(subset mask)

  • 默认子网掩码

A类:8位
B类:16位
C类:24位

地址规划

  • 举例

由子网掩码可知:172.10.1.7/16,所以网络地址为:172.16.0.0(主机位全为0),主机数:2^16,可用主机数: 2^16-2

例子:10.1.8.3/24的网络是什么?第一个可用主机是?最后一个可用主机?可用主机是多少?
10.1.8.0,10.1.8.1,10.1.8.254,$2^8$-2=254

  • 变长子网掩码

192.168.1.7/25

有类IP编址的缺陷

在设计网络时使用有类IP地址会造成地址的浪费。

划分子网方法

  1. 根据需要的子网数目来确定子网位数,但是要确保每个子网可用的IP地址数目大于等于本机数。
    优点:简单
    缺点:每个子网的实际主机数不同,但分配的IP地址数目相同,可能浪费IP地址

  2. 根据每个子网的主机数目来确定主机数位,然后确定子网数位。
    优点:比较充分地利用IP地址
    缺点:复杂

计算

科学但麻烦的方法

要转换二进制
二进制:1代表网络,0代表主机。

  1. 子网的数目 = $2^x$ (x代表子网位数)
  2. 可用主机数目 = $2^y$-2 (y代表主机位数)
  3. 主机位为全1的地址时广播地址=下个子网号-1
  4. 主机位全为0的地址是网络地址。
  • 利用子网数目计算子网掩码

把B类地址172.16.0.0划分成30个子网络,它的子网掩码是多少?

将子网络数目30转换成二进制表示11110
统计一下这个二进制的数共有5位
注意:当二进制数中只有一个1的时候,所统计的位数需要减1(例如:10000要统计为4位)
将B类地址的子网掩码255.255.0.0主机地址部分的前5位变成1
这就得到了所要的子网掩码(11111111.11111111.11111000.00000000)255.255.248.0。

  • 利用主机数目计算子网掩码

    把B类地址172.16.0.0划分成若干子网络,每个子网络能容纳500台主机,它的子网掩码是多少?

把500转换成二进制表示111110100
统计一下这个二进制的数共有9位
将子网掩码255.255.255.255从后向前的9位变成0
这就得到了所要的子网掩码(11111111.11111111.11111110.00000000)255.255.254.0。

  • 利用子网掩码计算最大有效子网数

    A类IP地址,子网掩码为255.224.0.0,它所能划分的最大有效子网数是多少?

将子网掩码转换成二进制表示11111111.11100000.00000000.00000000
统计一下它的网络位共有11位
A类地址网络位的基础数是8,二者之间的位数差是3
最大有效子网数就是$2^3$,即最多可以划分8个子网络。

  • 利用子网掩码计算最大可用主机数

    A类IP地址,子网掩码为255.252.0.0,将它划分成若干子网络,每个子网络中可用主机数有多少?

将子网掩码转换成二进制表示11111111.11111100.00000000.00000000
统计一下它的主机位共有18位
最大可用主机数就是 2^18-2(除去全是0的网络地址和全是1广播地址),即每个子网络最多有262142台主机可用。

  • 利用子网掩码确定子网络的起止地址

    B类IP地址172.16.0.0,子网掩码为255.255.192.0,它所能划分的子网络起止地址是多少?

利用子网掩码计算,最多可以划分4个子网络
利用子网掩码计算,每个子网络可容纳16384台主机(包括网络地址和广播地址)
用16384除以256(网段内包括网络地址和广播地址的全部主机数),结果是64
具体划分网络起止方法如下:
172.16.0.0~172.16.63.255
172.16.64.0~172.16.127.255
172.16.128.0~172.16.191.255
172.16.192.0~172.16.255.255

参考来源

快速但需要检验的方法

快的方式(Block):几个主机位,算B类地址比较麻烦.

  • 例子

132.56.45.7/30,网络位,主机位多少?

30转成二进制:1111,1100,后两位的0的块:$2^2$,一块最多4个主机(0-3,4-7,8-11)

CIDR 无类域间路由

cidrreport.org
无间路由(Classless Inter Domain Routing):由RFC1871定义。突破传统的地址分类边界,将路由表中的若干条线路汇聚成一条路由,减少了路由表的规模,提高了路由的可扩展性。

图中:转成二进制:
10.24.0000,0000.0
10.24.0000,0001.0
10.24.0000,0010.0
10.24.0000,0011.0

转二进制部分只有后两位不一样。把网络往前推(子网是Mask边长汇总是Mask变短),原来是24,变短就是22.

网关(Gateway)

用来转发来自不同网段之间的数据包。

实施FTP

  • 文件传输

FTP:文件传输协议 (华为居多),基于TCP,两个端口号,控制端口一般为21,而数据端口不一定是20,和FTP的应用模式有关,如果是主动模式,应该为20,如果为被动模式,由服务器端和客户端协商而定。
TFTP:简单文件传输协议 (思科居多),基于UDP

  1. 网络连通性
    ···bash SW1
    interface vlanf1
    ip address 10.1.1.1 255.255.255.0
    1
    2
    3
    ```bash SW2
    interface vlanf1
    ip address 10.1.1.2 255.255.255.0

测试连通性

1
ping 10.1.1.1.2
  1. 开启FTP服务

    1
    2
    ftp server enable
    diaplay ftp-servver # 查看状态
  2. 实施FTP
    开启3A(认证,授权,统计)

    SW1
    1
    2
    3
    4
    5
    6
    aaa
    local-user Endar password simple userName # 增加用户名和密码
    local-user Endar level 15 # 设置最高的访问权限,0-15级
    local-user Endar ftp-directory flash: # 共享所有目录,后面可以指定其他
    local-user Endar server-type ftp # 设置用户服务用于ftp协议
    save Endar.zip # 保持配置文件

客户端测试

SW2
1
2
3
4
ftp 10.1.1.1 # 后输入用户名、密码
dir # 查考目录
get Endar.zip # 获取文件
q # 退出

以太网IP头部概述和VRP相关讲解

一公司四个部门,5、25、27、15人,规划每个部门vlan,给固定长度掩码:192.168.1.0/27,192.168.1.32/27,192.168.1.64/27,192.168.1.96/27

IP包头的重要字段

VRP基础(应用)

VRP(通用路由平台)的FTP应用

可以Web、Cli登录
常用密码:[email protected]

设备初始化启动

bios 自检
内存检测
copy 数据(VRP包拷贝)
解压缩到内存
CTRL + B 停止自动启动(后可以初始密码)

命令行视图

  • 用户视图

清除、display、保存

  • 系统视图(system-view)

以中括号显示。可以display,但不能清除、保存
配置系统参数

  • 接口视图

  • 协议视图
    OSPF、BGP、is-is

    1
    2
    3
    system-view
    ospf # 进入 osp 协议设置
    bgp # 将进入 bgp协议设置

命令行功能

命令 解释
CTRL + A 光标移动到当前目录行最前端
CTRL + E 光标移动到当前目录行最末端
CTRL + C 停止当前命令的运行
CTRL + Z 回到用户视图
CTRL + ] 终止当前连接或切换连接
Backspace 删除光标左边的第一个字符
⬅ Or CTRL + B 光标左移一位
➡ Or CRTL + F 光标右移一位
TAB 输入一个不完整的命令按TAB进行补全

命令行在线帮助

  • 部分帮助
1
2
<Huawei>d?
<Huawei>display h?
  • 完全帮助
1
2
<Huawei>?
<Huawei>dislay?

命令等级

用户等级 命令等级 名称
0 0 访问级
1 0 and 1 监控级
2 0,1 and 2 配置级
3-15 0,1,2 and 3 管理级

允许某管理员保存系统配置,则可以将save命令的级别提高到4级,并定义只有该管理员有4级权限。就可以在不影响其他用户的情况下,实现命令的使用控制。

1
2
system-view
command-privileage level 2 view user save

用户界面

VTY接口最大可配范围:0~4

用户界面类型 编号
Console 0
VTY 0~4
R1
1
2
3
system-view
user-intetface vty 0 4
set authentication password clipher pass
R2
1
talnet 12.1.1.1
R1
1
2
diaplay users # 查看用户
user privilege level 2 # 设置用户登陆权限

user-interface maximum-vty number 可以配置同时登陆到设备的VTY类型用户界面的最大个数,如最大登录用户数设为0,则任何用户都不能通过Telnet或者SSH登陆到路由器。

  • 配置用户界面命令
命令 功能
idle-tineout 设置超时时间默认十分钟
screen-length 设置指定终端屏幕的临时显示行数(0不显示)
history-command max-size 设置历史命令缓冲区的大小
1
2
3
4
system-view
user-interface console 0
histoty-command max-size 20
indle-timeout 1 30 # 1分20秒(最好不要改))
1
2
3
system-view
user-interface console 0
screen-length 512 # 最大行数512

CTR 快捷键

命令 解释
CTRL + TAB 到达后一标签
CTRL + SHIFT + TAB 前一标签
ALT + 数字 直接到达某标签

配置标题消息

1
2
3
4
5
# 配置在用户登录前显示的标题信息
header login information "Welcome to huawei certification"

# 配置在用户登陆后显示的标题信息
header shell information "Please dont't reboot this devices"

dis current-configuration | ?
dis current-configuration | include header 显示包含 header 的命令有哪些

文件系统管理

基本命令

命令 功能
pwd 查看当前目录
dir 显示当前目录下的文件信息
more 查看文本文件的具体内容
cd 修改当前用户当前界面的工作目录
mkdir 创建新目录
rmdir 删除目录
copy 复制文件
move 移动文件
rename 村民们文件
delete / unreserved 删除/永久删除文件
undelete 恢复删除的文件
reset recycle-bin 彻底删除回收站的文件
save 保存配置,要在用户模式下

配置文件管理

  • 配置文件查询
命令 功能
diaplay curremt-contiguration 显示当前配置文件
diaplay saved-configuration 显示保存的配置文件
1
2
3
4
5
6
7
save Endar.zip # 保存配置

# 查看当前配置
diaplay current-configuration

# 显示保存的配置文件
diaplay saved-configuration
  • 系统启动文件查查
命令 功能
display startup 查看系统启动参数
  • 系统启动配置文件修改

startuo ? :

  1. path # 加载补丁
  2. save-configuration # 加载下次的配置
  3. system-software # 加载下次启动的软件
1
2
3
# 配置系统下次启动时使用的配置文件
startup save-configuration Ender.zip
dis startup
  • 比较当前配置和保存的配置
1
compare configuration
  • 配置文件重装
1
2
# 清楚下次启动时加载的配置文件
reset save-contiguration
  • 设置环回地址
    1
    2
    3
    system-view
    interface loopback 0
    ip address 10.1.1.1 32

存储设备

SDRAM、Flash、NVRAM、SD Card、USB

1
2
# 显示存储设备信息
diaplay version
  • 存储设备修复
1
2
3
fixdisk flash:

fixdisk ad1:

  Linux

评论

Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×